Hi all, new 07 3 Owner (MZR-CD) and lots of fun driving it - FMVperformance.com : The site for all your Ford Mazda and Volvo needs
 1Likes
  • 1 Post By MrOzzy
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 11-16-2018, 11:17 AM Thread Starter
Bicycle Rider
 
Join Date: Nov 2018
Location: Sydney
Posts: 4
Hi all, new 07 3 Owner (MZR-CD) and lots of fun driving it

Just got a 07 MZR-CD about a week ago, nice car and fun to drive needs a little work but most 10yo cars do, got a pretty good price on it I think because the DPF light was flashing and the guy told me he thought it was bad but only needed a DPF regen/reset which was a breeze thanks to this forum and a very helpful post by user 'reedweaver'. Bottom end inspected with my endoscope showed its clean as a whistle down there so Im pretty happy with the purchase and hopefully it'll be a reliable daily for a long time to come.

Anyways I'm having blast driving it but there's a small a problem I'm facing with my radio LCD info screen no longer displaying anything (this occurred after I unplugged it) which after reading online for many many hours made me decide to sign up so hopefully someone more knowledgeable than myself might be able to help me before I go buying new LCDs and radios trying to get this thing working properly.
MrOzzy is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-16-2018, 11:35 AM
mrb
Go-Kart Driver
 
mrb's Avatar
 
Join Date: Jan 2011
Location: vancouver
Posts: 64
Quote:
Originally Posted by MrOzzy View Post
Just got a 07 MZR-CD about a week ago, nice car and fun to drive needs a little work but most 10yo cars do, got a pretty good price on it I think because the DPF light was flashing and the guy told me he thought it was bad but only needed a DPF regen/reset which was a breeze thanks to this forum and a very helpful post by user 'reedweaver'. Bottom end inspected with my endoscope showed its clean as a whistle down there so Im pretty happy with the purchase and hopefully it'll be a reliable daily for a long time to come.

Anyways I'm having blast driving it but there's a small a problem I'm facing with my radio LCD info screen no longer displaying anything (this occurred after I unplugged it) which after reading online for many many hours made me decide to sign up so hopefully someone more knowledgeable than myself might be able to help me before I go buying new LCDs and radios trying to get this thing working properly.
Plugged back on?

The LCD without the factory radio would display only on the left side and for changing time would require the radio for adjustments.

The GT version displays fan speed, vents, temp and MPG

Last edited by mrb; 11-16-2018 at 11:36 AM. Reason: add
mrb is offline  
post #3 of 4 (permalink) Old 11-16-2018, 11:42 AM
Banned
 
Join Date: Apr 2018
Location: At the bottom of the California Sierra Mountains
Posts: 772
Send a message via Yahoo to M3RacerX
Welcome to the forum
M3RacerX is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 11-26-2018, 12:12 AM Thread Starter
Bicycle Rider
 
Join Date: Nov 2018
Location: Sydney
Posts: 4
Quote:
Originally Posted by mrb View Post
Plugged back on?

The LCD without the factory radio would display only on the left side and for changing time would require the radio for adjustments.

The GT version displays fan speed, vents, temp and MPG
Thanks for the suggestion yeah it was plugged back in it lit up and had lines but no infor, after a few hours poking and prodding and looking for the problem I figured out whoever the genius was that installed the head unit (and the can bus adapter) simply twisted all the wires together and then used electrical tape to secure/isoltate, the 12v for the can bus had simply come off so I spent a hour soldering everything up properly and used shrink tube to avoid the possible future sticky mess that electrical tape causes. I really hate electrical tape the way it leaves sticky residue shrink tube is always the way to go oh and actually soldering everything together also helps edit; by the way is the 'non gt version' supposed to display external temperature on the right or is it just completely blank there?
mrb likes this.
MrOzzy is offline  
Sponsored Links
Advertisement
 
Reply

  FMVperformance.com : The site for all your Ford Mazda and Volvo needs > Misc > Introductions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the FMVperformance.com : The site for all your Ford Mazda and Volvo needs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello all. Speed3 owner in Germany. herny316 Introductions 2 09-12-2018 04:01 PM
New Mazda3 owner RobertBarr Introductions 2 11-27-2017 11:09 PM
hello new fusion owner fusionXD Introductions 0 08-25-2017 02:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome