UPS damaged my parts during shipment!!! FAIL!!! - FMVperformance.com : The site for all your Ford Mazda and Volvo needs
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 08-18-2009, 10:56 PM Thread Starter
Grand Am Series
 
Join Date: May 2005
Location: Honolulu, HI
Posts: 331
UPS damaged my parts during shipment!!! FAIL!!!

A fellow forum member bought my MS3 sway bars and I shipped them out like a month ago. Somehow they went "missing" from the tracking info online. I called them to start a "trace" to find out 7 days later that it was in their "lost and found" warehouse labeled as "damaged". The operator I talked to couldn't give me the details of the damage, just that they'll send it back to me. I packed this box good also, used the same box COBB sent thier sways to me and I paacked it better.
WTH happened!? If it's damaged, I hope UPS Pays for it. This has never happened to me before so you can say I'm pretty ticked.
Any of you guys know how to handle this??


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
hawaii3xtacy is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-18-2009, 10:58 PM
Moderator of donks
 
halo0's Avatar
 
Join Date: Jul 2008
Location: teddy's crib
Posts: 32,022
Re: UPS damaged my parts during shipment!!! FAIL!!!

They'll pay for it up to the amount of insurance you purchased... Assuming you had the items adequately packed.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
halo0 is offline  
post #3 of 4 (permalink) Old 08-18-2009, 11:30 PM
Senior Member
 
Join Date: Jan 2008
Location: Alexandria, VA
Posts: 3,404
Send a message via MSN to verto
Re: UPS damaged my parts during shipment!!! FAIL!!!

musta been something pretty big to damage sway bars... the box is probably crushed or something and they labeled it as damaged without looking at the contents.

MS CAI - F2 CBE - ACT Flywheel - ACT Clutch - ACT Pressure Plate - MS 6 Speed Trans - TWM Desert Eagle Shift Knob - MS Springs - MS Shocks - MS Rear Camber Links - Techna-fit SS Brake Lines - Hawk HPS Pads - Cosworth BSD - Ported TB - 2.0L Oil Filter Conversion - LED Door Sills - Sharkfin Antenna - 35% Tint
verto is offline  
post #4 of 4 (permalink) Old 08-18-2009, 11:33 PM
Le Mans: Prototype Class
 
Join Date: Jul 2009
Location: Guam
Posts: 2,449
Re: UPS damaged my parts during shipment!!! FAIL!!!

That sucks. I have never had "great success" with filing claims for shipping stuff!! Hope it all works out!!

2010 Velocty Red MazdaSpeed3
2003 Alpine White BMW 320i

MS3 system build. 3 RE SL 10" subs. 2 Sundown amps. Alpine Type R Comps. 1/0 Wiring. False Floor

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Eternal is offline  
Sponsored Links
Advertisement
 
Reply

  FMVperformance.com : The site for all your Ford Mazda and Volvo needs > Misc > Lounge

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the FMVperformance.com : The site for all your Ford Mazda and Volvo needs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome